re = /(?<=\.)([^.>]+)(?=>$)/m
str = '<function __main__.percentile_50>
<function numpy.core.fromnumeric.sum>
<function numpy.core.fromnumeric.sum>
<function numpy.core.fromnumeric.mean>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end