const regex = /(<[^>]+.*?)(onabort|onactivate|onafterprint|onafterupdate|onbeforeactivate|onbeforecopy|onbeforecut|onbeforedeactivate|onbeforeeditfocus|onbeforepaste|onbeforeprint|
onbeforeunload|onbeforeupdate|onblur|onbounce|oncanplay|oncanplaythrough|oncellchange|onchange|
onclick|oncontextmenu|oncontrolselect|oncopy|oncuechange|oncut|ondataavailable|ondatasetchanged|
ondatasetcomplete|ondblclick|ondeactivate|ondrag|ondragend|ondragenter|ondragleave|ondragover|
ondragstart|ondrop|ondurationchange|onemptied|onended|onerror|onerrorupdate|onfilterchange|
onfinish|onfocus|onfocusin|onfocusout|onformchange|onforminput|onhashchange|onhelp|oninput|oninvalid,|onkeydown|
onkeypress|onkeyup|onlayoutcomplete|onload|onloadeddata|onloadedmetadata|onloadstart|
onlosecapture|onmessage|onmousedown|onmouseenter|onmouseleave|onmousemove|onmouseout|
onmouseover|onmouseup|onmousewheel|onmove|onmoveend|onmovestart|onoffline|ononline|
onpagehide|onpageshow|onpaste|onpause|onplay|onplaying|onpopstate|onprogress|
onpropertychange|onratechange|onreadystatechange|onredo|onreset|onresize|onresizeend|
onresizestart|onrowenter|onrowexit|onrowsdelete|onrowsinserted|onscroll|onseeked|onseeking|
onselect|onselectionchange|onselectstart|onshow|onstalled|onstart|onstop|onstorage|onsubmit|
onsuspend|ontimeupdate|onundo|onunload|onvolumechange|onwaiting)[^>]*>/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<[^>]+.*?)(onabort|onactivate|onafterprint|onafterupdate|onbeforeactivate|onbeforecopy|onbeforecut|onbeforedeactivate|onbeforeeditfocus|onbeforepaste|onbeforeprint|
onbeforeunload|onbeforeupdate|onblur|onbounce|oncanplay|oncanplaythrough|oncellchange|onchange|
onclick|oncontextmenu|oncontrolselect|oncopy|oncuechange|oncut|ondataavailable|ondatasetchanged|
ondatasetcomplete|ondblclick|ondeactivate|ondrag|ondragend|ondragenter|ondragleave|ondragover|
ondragstart|ondrop|ondurationchange|onemptied|onended|onerror|onerrorupdate|onfilterchange|
onfinish|onfocus|onfocusin|onfocusout|onformchange|onforminput|onhashchange|onhelp|oninput|oninvalid,|onkeydown|
onkeypress|onkeyup|onlayoutcomplete|onload|onloadeddata|onloadedmetadata|onloadstart|
onlosecapture|onmessage|onmousedown|onmouseenter|onmouseleave|onmousemove|onmouseout|
onmouseover|onmouseup|onmousewheel|onmove|onmoveend|onmovestart|onoffline|ononline|
onpagehide|onpageshow|onpaste|onpause|onplay|onplaying|onpopstate|onprogress|
onpropertychange|onratechange|onreadystatechange|onredo|onreset|onresize|onresizeend|
onresizestart|onrowenter|onrowexit|onrowsdelete|onrowsinserted|onscroll|onseeked|onseeking|
onselect|onselectionchange|onselectstart|onshow|onstalled|onstart|onstop|onstorage|onsubmit|
onsuspend|ontimeupdate|onundo|onunload|onvolumechange|onwaiting)[^>]*>', 'i')
const str = `Aim
To compare the clinical evolution of >70% asymtomatic in-stent restenosis in superficial femoral artery. (SFA) treated with endovascular procedure or conservative treatment.
Methods
Historical cohort study was performed in patients with femoral artery stent with an asymptomatic in-stent restenosis of 70-99%. Two groups: Conservative managment vs endovascular treatment.
In both groups we compared: Limb salvage and critical ischemia or limited claudication free survival rates ( <250m) , from initial stent treatment until the appearance of critical ischemia o major amputation ( Log-Rank, Kaplan Meier).
Primary permeability and assisted primary permeability were analized.
Results
From January 2010-December 2015, twenty three >70% in-stent restenosis were diagnosed in 20 patients with an average age of 78 years old (SD 9,6). Average follow-up was of 30,1 months. 12 patients (52,2%) received medical (Aspirin and Statins) and endovascular treatment. 11 patients (47,8%) received only medical treatment without an endovascular procedure.
No difference were seen in limb salvage.
Critical ischemia or limited claudication free survival rates were higher in the conservative treatment group vs endovascular group. (P=0,031)
Primary permeability was 14,2 months ( IC 8,2-20.2). Assisted primary permeability, 65,5 months ( IC 57,4-77,5).
Conclusions
In our experience treatment of severe asymtomatic lesions of in-stent stensosis in SFA does not reduce the risk of amputation, critical ischaemia o limitant claudication. In asymptomatic patients, conservative treatment could be a good option, without increasing the risk in amputation and critical ischema.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}