$re = '/cat(?:s?\.?|egory)?[ ]*(?:[ ]*(?:,|and|to)?[ ]*\d(?:\.\d+)?)*/i';
$str = 'Figure 1.2. Category 1.2 Figure 1.2.
Figure 1.2. Category 1.3 and 1.4 Figure 1.2.
Figure 1.2. Category 1.3 to 1.4 Figure 1.2.
Figure 1.2. CATEGORY 1.3 Figure 1.2.
Figure 1.2. Category 1.2, 1.3 and 1.5 Figure 1.2.
Figure 1.2. Category 1.2, 4.5, 2.3 and 1.6 Figure 1.2.
Figure 1.2. Category 1.2, 4.5, 2.3, 4.5 and 1.6 Figure 1.2. ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);