re = /(?<=\/)\((?>\((?<DEPTH>)|\)(?<=-DEPTH>)|.)*?(?(DEPTH)(?!))\)/
str = 'Test(b/(2c)) some (abc) test.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end