package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<script(.|\n)*?<\/script>`)
var str = `<script>
test
</script>
ohai
<script>
test
</script>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}