# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:start:(?=\w+(?:-\w+){2,9}:end)|(?<=-)\G)(\w+)(?:-|:end)"
test_str = ("-Should-not-match\n"
"Some text here and start:test-test-lorem-ipsum-sir-doloret-etc-something:end another something start:SIR-doloret-something:endand this is a non-match: start:SOMmething-blabla:end because hasn't got enough groups.\n"
" \n"
"This also start:REST-doloret-etc-something:end but not this: start:XXYY-lorem-ipsum-sir-doloret-etc-something-8-nine-ten-eleven:end because i\n"
"t's too long. start:XXYY-lorem-ipsum-sir-doloret-etc-something-8-nine-ten:end just there, and also start:XXYY-lorem-ipsum:end-garbage\n\n"
"This shouldn-t match also start:nothing:end! start:nothing-next:end\n\n"
"Test start:Something-nine-ten-eleven:end-bla-blastart:REST-doloret-etc-something:end---")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.