re = /\/\*@comment(?:(?!\*\/)[\s\S])*\*\//
str = '/*@comment
@title: Buttons
@name: block-name
@category: Category name > Sub category
@description: This is the description of the element
@html:
<div class="block-name"></div>
*/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end