$re = '/^augur\.scanners\.eset\.systems|h[1,3,5]\-aidc01\.eset\.com$/mi';
$str = 'h1-aidc01.eset.com
h3-aidc01.eset.com
h5-aidc01.eset.com
augur.scanners.eset.systems';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);