#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)<iframe.*?(width="[0-9]*")?\.?(height="[0-9]*")?\.*?src=".*?youtube\.com\/embed\/(\w*\-?\w*).*?(width="[0-9]*")?\.?(height="[0-9]*")?\.*?><\/iframe>"
Local $sString = "<iframe width="123" height="237"src="http://www.youtube.com/embed/IMtG_n1FpgA" frameborder="0" allowfullscreen></iframe>" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"<iframe width="560" height="315" src="https://www.youtube.com/embed/VsG2t-rKUmA" frameborder="0" allowfullscreen></iframe>" & @CRLF & _
"" & @CRLF & _
"<iframe id="cKOFUZFPYp8_Youtube_api" style="width:100%;height:100%;top:0;left:0;position:absolute" frameborder="0" allowfullscreen="1" title="YouTube video player" width="640" height="360" src="https://www.youtube.com/embed/cKOFUZFPYp8?controls=0&modestbranding=1&rel=0&showinfo=0&loop=0&fs=0&hl=en&enablejsapi=1&origin=http%3A%2F%2Fspiritualtv.org&widgetid=1"></iframe>"
Local $sSubst = "<video id=\"$3\" class=\"video-js vjs-default-skin vjs-fluid\" controls width=\"640\" height=\"264\" data-setup='{ \"techOrder\": [\"youtube\"], \"sources\": [{ \"type\": \"video/youtube\", \"src\": \"https://www.youtube.com/watch?v=$3\"}] }'></video>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)