re = /^(?(?!myword).)*$/m
str = 'This is the text
This is myword the text pass the test.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end