// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"createElement\(\s*\'(.*)\'\,\s*").unwrap();
let string = "return createElement(
'div',
{ className: 'sidebar-options' },
createElement(
'div',
{ className: 'account-options' },
createElement(
'div',
null,
'My Account'
),
createElement(
'div',
null,
'Sign Out'
)
),
createElement(TextField, { props: foo }, 'blah'),
createElement(
'div',
{ className: 'room-options' },
createElement(
'div',
null,
'Change Duration'
),
createElement(
'div',
null,
'Make Private'
),
createElement(
'div',
null,
'Delete Conversation'
)
)
);";
let substitution = "R.$1(";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}