$re = '/xiaoju(\d)/';
$str = 'xiaoju121';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);