#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:[-+]?\d*\.?\d+[\/*+-])*(?:[+-]?\d*\.?\d+)"
Local $sString = "5+5" & @CRLF & _
"5-5" & @CRLF & _
"5*5" & @CRLF & _
"5/5" & @CRLF & _
"5*6/2" & @CRLF & _
"+500" & @CRLF & _
"-500" & @CRLF & _
"500" & @CRLF & _
"test" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")