$re = '/(([a-zA-Z]){3})-(\d{3})(?=...)/';
$str = 'ACC-101 (LTI - test)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);