$re = '/\d+\D+(\d+)/';
$str = '340x9x20';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);