$re = '/^(MAS|VIS| CRE)\d\{11}/';
$str = 'MAS123456789
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);