$re = '/\w*[aeiou][aeiou]\w*/m';
$str = 'The team sat next to each other all year and still failed.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);