re = /(?<!т\.н)(?<!т\.к)(?<!e\.g)\.(?=\s+\p{L})/i
str = 'cats, e.g. Barsik, are funny. And it is true. So,'
# Print the match result
str.match(re) do |match|
puts match.to_s
end