import re
regex = re.compile(r"^[+]?([-\d]{8,15})\d$", flags=re.MULTILINE)
test_str = ("#Match\n"
"0414161592\n"
"+61414161592\n"
"04-141-61592\n"
"+61-4-141-615-92\n"
"+92-51-5520741\n\n"
"# Don't match\n"
"1--\n"
"--\n"
"#$@%^#$@# 2 \n"
"dafadf\n"
"10-asdf-1\n"
"-12-1-\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")