use strict;
my $str = '2 HCl + 12 Na + 3 (Na₃Cl₂)₂₄ → 2 NaCl + H₂';
my $regex = qr/(([0-9]* ??\(*([a-z]+[₀-₉]*)+\)*[₀-₉]*))/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}