package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((\w+\s+)+)`)
var str = `Eu adoro tomar suco de laranja.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}