package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\d{11}$`)
var str = `85930847392`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}