re = /(\w+)\.+(\w+)(?:\.+(\w+))?/m
str = '...aaa....bbb...XXX....eee...fff...YYY...hhh...ZZZ....'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end