package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<(?:(?(R)\w++|[^<>]*+)|(?R))*>`)
var str = `<tag allows="for nested" <tag />`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}