re = /\b\.net\b/m
str = 'Full-Stack Developer (Angular, .net Core, SQL) .network '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end