#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[&|;]?Adresa_Drzava(\=[^&;]*)?(?=&|;|$)|^$Adresa_Drzava(\=[^&;]*)?(&|;|$)"
Local $sString = "?&Adresa=dddddddd;Adresa_Drzava=Ma%C4%91arska;substring=0&catid=&Adresa_Mjesto_Naselje=&Adresa_Postanski_Broj=&mh=15"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")