$re = '/^(?(?=\d{4}$)..(\d{2}))$/m';
$str = '2014 - 14
2014';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);