$re = '/[1-9]/';
$str = '08° 28\' 00\'\' S / 140° 23\' 00\'\' E';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);