re = /((?<=#)\w+)/
str = 'Cookie Recipe for n00bs
#cookie #recipe #chocolate To do this you have to etc...
Bla bla bla mumbo jumbo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end