package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ism)\[(.*?)\]`)
var str = `[данные1][данные2][данные3]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}