using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^select\s+(?<columns>.*?)\s+from\s+(.*?)?((where\s+(?<where>.*?))?(order by\s+(?<order>.*?))?(limit\s+(?<limit>(.*?)))?);";
string input = @"select * from mytable where x=10 and t=""abc"" order by abc, def LIMIT 10,10;";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}