import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*\\/(.*)\\.py.*::(.*?(\\[.*?\\])?)$";
final String string = "CERTIFICATION/repos_1/test_examples_1_01_C.py::test_case[6]\n\n"
+ "CERTIFICATION/repos_1/test_examples_2_01_C.py::test_case[7]\n\n"
+ "INTEGRATION/test_example_scan_1.py::test_case\n\n"
+ "INTEGRATION/test_example_scan_2.py::test_case";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}