package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<div>(.*?)<\/div>`)
var str = `this is <div> my test </div> string <div> I want to extract this </div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}