package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<(?<tag>\w+).*?>(?<content>.*?)<\/\k<tag>>`)
var str = `<p grrh>dezfrz</p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}