re = /\/\/.*|\/\\*(?>[^*]+|\\*(?!\/))*\\*\/|\"(.*?)\"/
str = '// "No Match"
MessageBox.Show($"Test \\"{Path.GetFileName(Test)}\\"Right?", "TEst", MessageBoxButtons.YesNo, MessageBoxIcon.Asterisk);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end