$re = '/^(\w+)(?=(?:_[LR]_\d{0,4})|$)/m';
$str = 'KEEP_THIS_L_1234
KEEP_THIS_R_12
KEEP_THIS';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);