$re = '/[0-9-.E]+./';
$str = 'gggg sdfasd -2354 gsdfgdfg
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);