re = /([^?=&]+)(=([^&]*))?/i
str = 'sender=11&receiver=2&subject=3&message=4
sender=AOFJOIA&receiver=p2308u48302rf0&subject=(@#UROJ)(J#OFN:&message=aoefhoa348!!!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end