package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Node.+?label="\{\{(?<SRC><s[0-9]+?>[a-z0-9]+?)\}|(?<NAME>.+?)\[ORD=(?<ORD>[0-9]+?)\]\|(?<ID>[a-z0-9]{14})|\{(?<DEST><d[0-9]+?>[a-z0-9]+?)\}\}"\];`)
var str = `Node0x7fd34984d728:s1 -> Node0x7fd34984d600:d0;
Node0x7fd34984d850 [shape=record,shape=Mrecord,label="{Register %vreg13|0x7fd34984d850|{<d0>i32}}"];
Node0x7fd34984d978 [shape=record,shape=Mrecord,label="{{<s0>0|<s1>1}|CopyFromReg [ORD=1]|0x7fd34984d978|{<d0>i32|<d1>ch}}"];
Node0x7fd34984d978:s0 -> Node0x7fd3486095f0:d0[color=blue,style=dashed];
Node0x7fd34984d978:s1 -> Node0x7fd34984d850:d0;
Node0x7fd34984daa0 [shape=record,shape=Mrecord,label="{Register %vreg14|0x7fd34984daa0|{<d0>i32}}"];`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}