$re = '/(.+?)~.*[([]\1[)\]].*/';
$str = 'The Series~The Book Title (The Series)
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);