$re = '/\A(?=[a-z])(?=(?:\D*\d){4,})/';
$str = 'z15a62
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);