package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b6(?:011|5[0-9]{2})[ -]([0-9]{4}[ -]){2}([0-9]{4})\b|\b6(?:011|5[0-9]{2})[0-9]{12}\b`)
var str = `Discover
Requirements: Discover cards start with the number 6011 or 65 and have 16 digits.
Pattern Parts:
Starts with number 6011 or 65, has 16 length, and has space or dash:
1) \b6(?:011|5[0-9]{2})[ -]([0-9]{4}[ -]){2}([0-9]{4})\b
Starts with number 6011 or 65, has 16 length, and has no space or dash:
2) \b6(?:011|5[0-9]{2})[0-9]{12}\b
Combining 1-2 to form one pattern:
\b6(?:011|5[0-9]{2})[ -]([0-9]{4}[ -]){2}([0-9]{4})\b|\b6(?:011|5[0-9]{2})[0-9]{12}\b
Test Cases:
Positive (Should fire):
16 length, no space, start with 6011 Here is the cc: 6011123412341234 Thanks.
16 length, dashes, start with 6011 6011-1234-1234-1234
16 length, spaces, start with 6011 6011 1234 1234 1234
16 length, no space, start with 65 6521123412341234
16 length, dashes, start with 65 6521-1234-1234-1234
16 length, spaces, start with 65 6521 1234 1234 1234
Embedded in sentence with space:
16 length, no space, start with 6011 Here is the cc: 6011123412341234
16 length, dashes, start with 6011 Here is the cc: 6011-1234-1234-1234
16 length, spaces, start with 6011 Here is the cc: 6011 1234 1234 1234
16 length, no space, start with 65 Here is the cc: 6521123412341234
16 length, dashes, start with 65 Here is the cc: 6521-1234-1234-1234
16 length, spaces, start with 65 Here is the cc: 6523 1234 1234 1234
16 length, no space, start with 6011 Credit Card#:6011123412341234
16 length, dashes, start with 6011 Credit Card#:6011-1234-1234-1234
16 length, spaces, start with 6011 Credit Card#:6011 1234 1234 1234
16 length, no space, start with 65 Credit Card#:6521123412341234
16 length, dashes, start with 65 Credit Card#:6521-1234-1234-1234
16 length, spaces, start with 65 Credit Card#:6523 1234 1234 1234
Negative (Should Not Fire):
16 length, no space, not start with 6011 6012123412341234
16 length, dashes, not start with 6011 6012-1234-1234-1234
16 length, spaces, not start with 6011 6012 1234 1234 1234
16 length, no space, not start with 65 6612123412341234
16 length, dashes, not start with 65 6612-1234-1234-1234
16 length, spaces, not start with 65 6612-1234-1234-1234
16 length, no space, start with 65, embedded Credit Card Number6521123412341234
16 length, dashes, start with 6011, malformed 601-11234-1234-1234
16 length num matching pattern but embedded User ID: 0000006011123412341234000000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}