$re = '/(.+?)\1+/';
$str = '1234123412341234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);