$re = '/^(.+?)\1+$/m';
$str = '12341234123123
12341234123412341234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);