package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*?) vs (.*?)`)
var str = `tyler vs ryan`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}