const regex = /<(\s+)?img(?:.*src=["'](.*?)["'].*)\/>?/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(\\s+)?img(?:.*src=["\'](.*?)["\'].*)\\\/>?', 'gmi')
const str = `ada<img src="ere" />
<img src="2452df" />
<img src="65" />
sd
<img src="ere" />
asda`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}