package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\p{Lu}\p{M}][\p{L}\p{M},.'-]+(?: [\p{L}\p{M},.'-]+)*$`)
var str = `John Smith
Alberto del Muerto
INCORRECT
" John Smith "
" John Smith"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}