$re = '/((?:(?:PUBLIC|PRIVATE)[ \t]+)*(?:(?:DEFAULT)[ \t]+)*PROPERTY[ \t]+(?:GET|SET|LET)[ \t]+(?:(\w+)(?:[ \t]*\(([^\(\)]*)\))*))(?:.*)END PROPERTY/ims';
$str = ' public default property get abc (a, b, c)
ksdjflkj lkjlk jd()
lkjdlkfj
lkdjf (sdfd())
kljlkj sd
fd fdsflkdsjjdsk lkjsdlkj
end property';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);