$re = '/\\\\d+(-\\\\d+)/';
$str = '861--900/741-750/611-620';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);