# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*\"state\":\"CA\".*\"active\":true.*)"
test_str = ("{\"id\":1,\"last\":\"Doe\",\"first\":\"John\",\"location\":{\"city\":\"San Francisco\",\"state\":\"CA\",\"postalCode\":\"94105\"},\"active\":true}\n"
"{\"id\":2,\"last\":\"Dosdsf\",\"first\":\"Jane\",\"location\":{\"city\":\"San Jose\",\"state\":\"CA\",\"postalCode\":\"94110\"},\"active\":false}\n"
"{\"id\":3,\"last\":\"Dodsde\",\"first\":\"Johnathan\",\"location\":{\"city\":\"Los Angeles\",\"state\":\"WA\",\"postalCode\":\"90045\"},\"active\":true}\n"
"{\"id\":4,\"last\":\"Dhruvil\",\"first\":\"Darji\",\"location\":{\"city\":\"San Francisco\",\"state\":\"CA\",\"postalCode\":\"90304\"},\"active\":false}\n"
"{\"id\":5,\"last\":\"Meghal\",\"first\":\"Gandhi\",\"location\":{\"city\":\"Irvine\",\"state\":\"WA\",\"postalCode\":\"94155\"},\"active\":true}")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.